Skip to main content

Site Navigation

Your Account

Choose Language

New Fans Not Working

A few weeks back my fans stopped working on my Boxzy Milling machine. I ordered 2 new fans and just now got around to installing them. I checked all connections and for some reason when I power up the machine, the new fans do not work either. Is there something else that is possibly keeping them from performing. Thank you.

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

When I touch the motors on the fans, they are slightly warm to the touch so it appears to be current getting to them.

by

Add a comment

1 Answer

Chosen Solution

That's extrmely odd, those fans are basically hard wired directly to the power input, there is nothing in between them.

Is it possible you plugged them in reverse? That would do what you described.

If that's not possible, check the pins on the board, a pin may have broken loose from the board under the white connector.

Was this answer helpful?

Score 0

Comments:

I spoke with Justin. I'm sending the unit in. Everything looks good and even the motors get warm. Wiring is correct, but still no fans. Also and this happened before after I first received it, a small amount of electrical current can be felt traveling through the gantry when you touch it. I put a meter on it and while the read out is very low I don't think this should happening.

by

Add a comment

Add your answer

Glenn Auer will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 2

All Time: 18