Skip to main content

Site Navigation

Your Account

Choose Language

Need help troubleshooting your BoXZY 3D Print Head? You're in the right place!

26 Questions View all

Y-Axis jittery/inverted all of a sudden

Hello, I am having a new problem with my Boxzy. In the middle of a print, it began printing into y-axis values outside of the 3D model and was trying to go beyond the y-axis max limit. It kept hitting the limit switch and sounded really rough. This has never happened before now.

To preface: I recently added the Boxzy heated bed, but it was working fine for several prints. This required a firmware update for the heated bed. I also recently removed the print head to fix a clog, but re-assembled and made it through 2 hours of printing before this issue. I’ve tried swapping the limit switches X to Y with no change in behavior. I tried removing the heated bed completely and reloading the firmware for no heated bed. I’ve re-installed Repetier as well. I’m using a 2018 Macbook Pro.

If I try to manually increase the y-axis value by 10 mm, it seems to randomly move +10 or -10, even though I am only pressing the +10 button. It is as if the relative y movement value gets inverted?

As shown in the attached video, if I send it home on the y-axis, it goes to the outer limit switch and back to home, but then jitters violently back and forth as it hits the home limit switch. Sometimes it stops short of the switch and does the same jittering. All starts and stops on the y-axis seem rough.

When I tried a print with a ‘square’ base, it began printing as shown in the pic, which shows the y-axis being flipped half way through.

Block Image

Any help you can provide will be greatly appreciated.

Thanks in advance!

Jeffmo77

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

This behaviour is typical of a weak motor connection to the main board. This is somewhat common with those black connectors, and usually everything looks to be fine.

If the connectors is pushed all the way into the board, and this issue remains, the internal parts of the connector have become stretched out, or pushed back in the connector. The best way to repair this is to solder on new XH 4 pin connectors to the X and Y motor wires. You can also attempt to repair the black connector, but this doesn't work many times, and it is not a permanent solution.

Was this answer helpful?

Score 1

Comments:

Thank you for the suggestion. I looked at the motor wires, and they were still glued in place and looked good. I tried switching the X and Y motor wires, and the problem moved to the x-axis. That means the problem is coming from the board or the firmware. Any thoughts? Could the addition of the heater have caused a board problem like this?

by

It is unlikely the additional heater was the direct cause. That behavior requires the motor coils to reverse polarity intermittently. If the issue stays with the slot on the board, and not the motor, the issue is that either the red driver board for that axis has failed, or the pins/solder of the output have broken or become loose. A good test is to very carefully swap the X and Y driver boards. If the issue stays with the slot, it's a physical broken connection on the main board. If the issue follows the red driver, the driver board is faulty. Make sure not to swap any driver but X and Y, and do not install a new driver without proper preparation, or more damage can occur.

by

Thank you! It seems that the driver is the culprit. I will replace and see how it goes.

by

Add a comment

Add your answer

Jeffmo77 will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 3

All Time: 28