Skip to main content

Site Navigation

Your Account

Choose Language

Stepper driver current limit setting?

For future reference, what current setting does the Boxzy team use for the stepper driver boards (in Amps and mV)?

Just in case, because they do get warm and warm things fail!

Thanks!

Gary

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Chosen Solution

While here doing some diagnostics on my X-axis, I just measured the Vref setting on my boards for all three (X, Y, and Z) axis and the Vref pin is measuring ~0.700 volts on all three. The best I can tell, the Rs (sense resistor) value on these boards is 0.05. It's difficult to measure them with my meter due to the low resistance value, but that's what seems to be written on it for a value, assuming my eyes are reading it right, and that matches the following web sources.

According to both the Pololu and RepRap websites for measuring/setting the current limit:

http://reprap.org/wiki/Pololu_stepper_dr...

https://www.pololu.com/product/1182

This comes out to be:

Itrip = Vref/(8*Rs)

Itrip = 0.7/(8*.05) = 1.75 amps

Pololu has a nice video showing how to measure and set it:

https://www.pololu.com/blog/484/video-se...

I cross-checked the resistance divider bridge with my meter, and the potentiometer appears to be a 10k pot, set to 4.3k (with respect to the ground side), in series with a 20k resistor. This matches the schematic on the Pololu website at the above links.

It also verifies my voltage reading, as the divider bridge would be 4.3k/(10k+20k) = 0.143. Multiply that by the 5 volt logic supply and you get 0.716 volts which is close enough to the 0.700 volts that I measured.

So -- from the best I can tell, they are set to 1.75 amps...

NOW... for my big question... WHY did they clip the step-set pins on the drivers and not just set the jumpers on the Ultimaker 1.5.7 board correctly as it was intended to be done??? Can anyone explain that one to me???

I'm looking at replacing my X-axis stepper drive board to see if it solves a mystery I've experienced a couple of times during printing where my X-axis will suddenly shift. The first time it happened was a really long (17+ hour) print and I was only monitoring via remote camera when it happened. Even though it was PLA, I had some warping issues in the part that did cause one corner to pop up about the right amount to cause the 10mm X-axis shift that occurred and so I dismissed it as simply being a head to part collision that somehow shifted it.

But then last night, I was doing a quick 30-minute print with some Nylon 230 and everything was adhering perfectly and definitely was no head collision or binding problems. I was sitting here watching the printer and all of a sudden halfway through the part, I realize my X-axis had mysteriously shifted by 5 or 6mm and it was printing in mid-air.

What was really frustrating was that the first layer and raft and all were absolutely perfect and the adhesion to the print bed was as perfect as one could get for nylon -- one of my best ever for getting it to stick, all after a couple of hours of failed attempts at getting it to stick.... and then I was robbed of my print because of the X-axis problem...

So... I'm going to be swapping out some stepper driver boards, but if anyone can explain why they cut the pins on the step-setting inputs and didn't just use the jumpers, please let me know! I've looked at the Ultimaker 1.5.7 schematic and cross-checked with details on the driver board itself, and I can't see why they did that.

Was this answer helpful?

Score 4

Comments:

Nice research Donna. Thanks

by

So, asking again. Are the Boxzy stepper drivers supposed to be set to 1.75A?

Does Boxzy set the drivers current setting during assembly or do they just clip the pins and go?

And why do they clip the pins?

by

Good question. I did replace my X-axis driver last night. It was a cheap Pololu knockoff, and had some differences. For one, its Rs is 0.1 instead of 0.05. And it has a 30k resistor in series with the pot instead of 20k. In actuality, it's better situated for the A4988 chip's current range than the authentic Pololu. But, with the 2x Rs value, it requires a 2x Vref and yet the voltage divider only allows for 1/4 Vcc instead of 1/3 Vcc range. So... I could only set it to approx 1.5 amps max. While the A4988 is rated 2A max, I don't know it likes that continuously. The new module actually seemed to make that axis a little more quiet. Didn't have any issues in last night's printing. So we'll see.

I did initially try to change the jumpers on the UM board and not clip the pins, and either it doesn't work or I didn't jumper it correctly, as it ran at 1/2 the step rate it should. I needed to get on with printing, so I switched the jumpers back and clipped the leads and it works. But that needs more investigation.

by

I tried running the Boxzy at a lower voltage, just as a test. The steppers ran super quiet -- until it barfed and skipped steps, all at once.

Oh, and I'm sorry, Donna - my questions above were directed to the Boxzy folks.

by

The problem with lowering voltage is you lose torque. On model trains, for example, the systems in the old days only varied voltage and you had to crank it up to get it to move and then it jerked and threw half the cars off (OK, not quite that bad). A better way was to use full voltage with PWM. This allows full torque from zero speed on up.

Speaking of the jumpers, I was just here wondering if anyone has tried doubling the resolution of the X and Y axis to match the Z axis? The Z has twice the steps per revolution.

I haven't fully analyzed the firmware code, but I *think* it would only require changing the jumpers on the drivers and changing the following lines in the Configuration.h firmware file:

#define XAXIS_STEPS_PER_MM 160

#define YAXIS_STEPS_PER_MM 160

#define ZAXIS_STEPS_PER_MM 320

It would be an interesting experiment. Maybe that doesn't give enough torque on X/Y for the mill? But for the laser and printer... Hmm...

Yep, I knew to whom your questions were addressed - was just thinking out loud.

by

Show 21 more comments

Add a comment

The motors are rated for 2.0 amps per coil at 2.8V. I'm not sure what the actual drivers are set for however. I do know the A4988 drivers max out at 2.0 amps.

Was this answer helpful?

Score 0

Comments:

2.8V? Wow. Okay. I guess I'm bewildered by the 19V supply. Thanks!

The question was in reference to this tutorial.

https://www.youtube.com/watch?v=89BHS9hf...

by

No problem! Ultimately the rated voltage is what allows the motor to draw the specified current. As in, at 2.8V the motor will draw 2 amps based on its resistance. The current is actively controlled by chopping the frequency the power is supplied at. In essence the driver controls voltage to the motor to control how much power it is using (there's a lot more to it, but that's the basic idea). 19V is primarily about the other functions like heating, fans, etc., It also requires a lot more current when sending power at a lower voltage, so a higher voltage with lower amps can reduce the load on the system and provide the watts needed.

by

Add a comment

Add your answer

Gary will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 3

Past 30 Days: 11

All Time: 939