Skip to main content

Site Navigation

Your Account

Choose Language

These guides and questions explain advanced milling topics. Make sure you've completed 2.3 CNC Milling with BoXZY before moving on to these guides.

14 Questions View all

Falling off Z axis alignment mid print

So I have been having really good results for the last few months with Boxzy, but recently I am having a major new issue... Suddenly I am having spontaneous axis fall offs that I can't find any explanation for. I think that this issue has gotten progressively worse, I did have a few destroyed pieces along the way that I couldn't make sense of (but had stepped away from boxzy when the incident occurred so it was hard to say for certain), though in the last week or so, every milling job I have attempted has been ruined dues to the same issues.

Part 1 is that the limit switches for the carriage axes (XY) are doing something weird, I have been assuming due to wear and tear on the connector plug, it seemed a tad loose to me, and usually reaffirming that connection works here. So the two parts of this problem are 1) when homing the Y axis the limit switch occasionally will not trigger causing boxzy to repeatedly ram into the wall, and 2) I have had a few instances where the X/Y will fall off mid print leading to 3d prints out in mid air, and CNC tearing through workpieces at depth (no good on either account!) So I was wondering if anyone has come up with a good way to make that top connection a little more rigid, because I only see that problem getting worse.

Part 2 is a much bigger issue I can not make heads or tails of. The Z axis abruptly falls off the appropriate height mid print in CNC. This has lead to many destroyed workpieces, a couple of destroyed bits, and unnecessary wear on Boxzy I assume as well. I have watched it occur 3 times just now while milling a piece of acrylic and have no indicators of what is happening. It would be milling away fine, then suddenly it would not retract as high as it should and then would plunge 6x deeper than it should. What I do know: the limit switches are not being triggered accidentally, the milling head is secured firmly and not moving, the endmill is secured in the collet and not slipping. Anyone else have this issue, or any suggestions on troubleshooting, or what it might be?

Please help! I am finally getting up to speed with boxzy, and have made some wonderful objects, but this issue doesn't seem to be going away and makes boxzy essentially unusable. Thanks!

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

@james_nutter I've asked the team to send a BoXZY fix it kit to you with some extra little odds and ends that may help you. Expect them in a week or so. I hope they are useful for you, let me know if you have any questions. Enjoy the holidays.

by

Add a comment

2 Answers

Chosen Solution

TLDR:

X&Y Limit switch harness pin had come loose from use, replaced with fix it kit harness with improved glue and harness assembly, much more sturdy

Z axis missing steps mid program was fixed by using the recommended usb cable (had previously been using 25' cable)

There were lingering missed steps (much less pronounced) after these fixes, so I double checked the interface installation and made sure to remove the original interface per Just Helping's answer and that seems to have remedied these lingering glitches

Though if you are having these issues there is a lot of great troubleshooting info under Just Helping's answer

Was this answer helpful?

Score 1
Add a comment
Most Helpful Answer

It's really exciting to hear you're getting some great use out of BoXZY! I know it was touch and go getting started with the random hiccups.

First, the limit switch issue. You are likely correct that you have a loose connection in that joint. Those early machines didn't have the tightest connections inside of the gantry. The easiest way to deal with this is hot glue. You can force it down in that joint and make everything very rigid, and it's easy to remove. But at this point I might take the limit switch cap off the gantry and secure the wiring with some hot glue and heatshrink internally as well. I can ask Alex to do a write-up for removing, tightening and securing everything if you want to do this. Also, If you'd like I can ask the team to send you a "glued" harnesses and a glued gantry plug. They have been using a special glue to keep everything rigid and stop the internal pins from moving around. Originally they only used this for the main harness, the earliest ones didn't have it anywhere. XY limit switches are a simple thing to play with, it's nearly impossible to permanently damage anything that can't be very easily repaired. It's just wires and switches.

Missing steps (printer moving away from the correct work area) is a little more complicated but still usually pretty easy to deal with. The majority of the time the machine is missing steps due to a cooling issue. The drivers overheat and reach the current cutoff limit for heat. They momentarily drop out to cool down and try to pick back up as if they had been working the whole time, usually far offbeat. I would check to make sure the fan filter is not clogged or dirty, and that your fans are still running at full power. The fans on the early machines have been proven to last roughly 10,000 hours of use. Since they run continuously, leaving the machine powered up when not in use can dramatically shorten their life. After 10,000 hours of so they begin to slow down and eventually stop running at all. Check them to verify they are producing reasonable airflow. You'll also want to make sure the circuit board itself still has all of the heatsinks, that they are not loose, and that they are clean and free of dust. If all else fails, it's not impossible for a driver to go bad. That's not likely the issue if this is happening in both axis rather than just one, but it's worth mentioning.

Missing steps can also be a purely mechanical issue. Making sure you can turn each axis by hand without feeling major catches or grit at any points (a little should be expected) will let you know whether you may need to replace or grease some bearings. If a bearing is randomly hanging up this can lead to the same symptoms as overheating drivers.

What you've described with your Z fits in "missing steps", but since the Z is a little different I'll offer some other thoughts for it as well. Debris can build up under the machine and fill the Z pulleys and belts causing them to jam from time to time, you'll want to make sure you vacuum under the machine frequently or raise it up with some feet or hockey pucks. Since the pulleys sit very low to the table, imperfections or softness in the table surface can cause something to touch them and jam them up. I set my machine on cardboard and couldn't figure out for the life of me why it was missing steps, turns out the feet had dug in just a little and the pulleys were directly against the cardboard. Otherwise, the same things for the X and Y hold true for the Z. You'll want to verify cooling and turn the pulleys by hand to verify there it's not extremely tough to rotate in an any specific areas.

Also, it's unlikely this is the issue, but the early Interfaces had some communications glitches that could randomly ruin a print. It's a good idea to have the latest, make sure you completely remove the old interface or the glitches will remain even with the new one.

Removing the Old BoXZY Interface

Was this answer helpful?

Score 1

Comments:

Thank you to you and team boxzy for the fix it kit! So far I believe that I have solved the y axis issue. I disassembled the limit switch housing and checked every connection, and did find that one of the leads on the harness had become recessed. I replaced with the new (and much more sturdy) harness and hot glued to add extra rigidity on the carriage and all seems good there.

As for the z-axis step missing... I checked the mechanics and it moved very smoothly when turned by hand, the belt tension was good, and no teeth were missing on the belt. I lubed everything while I was at it. I cleaned out from under boxzy, and raised on stilts. Cleaned the fan screens as best I could (though not perfect, suggestions?), and both fans are pulling enough air to hold a piece of paper. And I swapped the Z driver for one of the new ones that have extra heat sink plaster (which I figured would increase heat transfer through the heat sink?). And I seem to still have the issue.

by

I ran the same program which is essentially just a series of shallow holes in a grid, and it got maybe 1/3 of the way through fine and then suddenly didn't retract all the way and then started cutting deeper in all subsequent holes. So there is a lot of repetitive up and down on Z before it occurs.

I will try to reinstall the interface, but I am 99% certain I have the most recent version and followed these steps when installing.

One thing that dawned on me is if the length of the USB cord is relevant? I am not using the cord that came with the kit, I have boxzy set up in a small room adjacent to where my pc is set up (desktop) and so I am using a 25' usb cable to reach it. I don't know why it would suddenly be causing a problem, but I remember seeing something about the usb cable early on.

by

You are so very welcome! Before we go into other possible causes, can you run a test for me? Can you go into your EEPROM settings and change "Z-max federate" to 10 (it should be 20 now) and try running the file again? (I'm assuming you haven't made any personal EEPROM modifications to the feedrates and acceleration/XY jerk prior, if you have, let me know that could be the cause) The results of that test will tell me a lot.

You said earlier you were confident the limit switches were not being activated accidently. How did you verify this? Did you only visually verify nothing was hitting them, or did you make sure they also weren't shorting on anything electrically? When I was milling brass at one point, the brass debris built up on the limit switch and would occasionally short the limit switch pins together giving me exactly what you have. Took me forever to locate that problem, visually it didn't look like it could be the issue.

One last question, do you have less of an error now than you did before? Or is it very similar?

by

On the USB cord issue, it is definitely longer than recommended and can certainly cause this type of issue. However, as long as it has ferrites and is a high quality shielded cable, that was working prior, I will assume it isn't the issue until we have run out of other possibilities.

by

Okay, I did the test and instead of not retracting as high and subsequently plunging deeper (by ~2mm) after 60 accurate depth holes, it looks like it over-retracted and began milling too shallow (also by ~2mm) after 25 accurate holes. Seems like one incident and then it remains regular. What does this tell us?

As for the limit switches I did a visual and hand check of the switches themselves and the connecting wiring, everything seems properly and firmly connected, no debris buildup I can see. And I have thus far only milled wood and acrylic, so I shouldn't have much highly conductive micro debris kicking around.

As for if it had improved, it is hard to say because in the first piece I was milling through a thin piece of material, and I didn't notice it was malfunctioning until later, so beyond knowing it was deeper than it should have been at the end, I don't have a depth reference like in the test pieces since. If I were to venture a guess based on when I noticed I would say it is roughly the same.

by

Show 19 more comments

Add a comment

Add your answer

James Nutter will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 4

Past 30 Days: 16

All Time: 654